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Accessibility refers to making online information easy to obtain for people with various levels of
eyesight, hearing capacity, and motor skills. Making the information on a Web page available to all
people, including those with disabilities, is the goal of creating and presenting accessible e-Learning
content. By developing accessible Web pages with ToolBook your content will reach the widest audience

possible.
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Understanding accessibility

There are many ways to access visual and auditory information through a Web browser. To improve
legibility, some people may increase the font size for text in their browser and others may use text
maghnification software. People with vision impairments can listen to text as it is vocalized by automated
screen reader software. When audio is included as part of a video or media presentation available on a
Web page, closed captions can convey the audio content as text. Other techniques are available and
new technologies are being developed to meet diverse needs.

You can develop accessible courses by following the guidelines developed by the Web Accessibility
Initiative of the World Wide Web Consortium (W3C). For more information, visit
http://www.w3.org/TR/WCAG10-CORE-TECHS/

About assistive technologies

Assistive technologies allow people with disabilities to interact with computer hardware and software.
Hardware solutions include various types of input devices such as larger keyboards and eye-gaze
pointing devices. Assistive software includes voice recognition programs, screen magnification, keyboard
enhancement utility programs and more.

In the accessibility guidelines developed by the Web Accessibility Initiative, many of the provisions
address vision impairments. One way to access computer-based information is by using a type of
software program known as a screen reader which translates text displayed on a computer screen into
audio output or refreshable Braille displays. Certain conventions are necessary to allow the person using
the screen reader software to interact with objects on the page, such as using the Tab key to move the
focus from one object to another on the page.

If you plan to develop e-Learning for a small or limited audience, you may be able to determine in
advance the types of assistive technologies in use by the people who will interact with your Web pages.
You can add this to your project plan and prepare material that meets the needs of the audience. For a
large audience, the best way to develop accessible content is to follow the guidelines developed by the
Web Accessibility Initiative of the World Wide Web Consortium (W3C).

About section 508

The Congress of the United States amended Section 508 of the Rehabilitation Act to require Federal
agencies to make their electronic information accessible to all people, including those with disabilities.
You can find out more about the regulations contained in section 508 by visiting
http://www.section508.gov/

The provisions in section 508 aim to ensure that visual and audio content is available in a format that
can be understood by most people. Alternative methods for conveying information are promoted, such
as the addition of text descriptions for graphics.
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Designing accessible Web pages

While you are planning your project, consider the following ways to present information in an accessible

manner.

Descriptive text

Provide text descriptions for each graphic image to briefly explain what is shown in the graphic. These
alternate text descriptions can be interpreted by screen reader software and read by people who have
graphics turned off. For more information about creating alternate text descriptions, see the next
section, “Using the accessibility features in ToolBook.”

Navigation

Create pages that can be navigated by using only the keyboard, as some people are not able to use the

mouse to make selections. Buttons that allow a user to make a selection or trigger an action should be

included in the tab order. Additionally, text fields that allow the user to enter text should be included in
the tab order.

Color

Use a text color that provides a strong contrast with the background color to make the text as legible as
possible. For those people who may not be able to distinguish between certain colors, include graphics
and section headings that can be understood without reliance on the specific colors used.

Media files

Video, audio, and other types of media files can be inaccessible to people with visual or hearing
impairments. If you plan to include media files, provide an alternate means to convey the information
contained in the media files. For example, you could include a text transcript of an audio file or a
description of a video file. Text is accessible to most people and can be understood by the current
assistive technologies in use.

Using the accessibility features in ToolBook

You can create a book with an accessible design by using objects from the Accessibility Catalog. The
Accessibility Catalog contains ready-to-use objects such as multiple-choice questions, buttons, text
fields, media players, and navigation links. Choose objects from the Accessibility Catalog in ToolBook to
display your text, graphics, and other content.

» To open the Accessibility Catalog:
1. From the View menu, choose Options, Catalog, Location.

2. Choose this catalog file:
c:\Program Files\ToolBook\ToolBook 11.5\Accessibility Catalog\catalog.ini
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It's a good idea to start testing your ToolBook content for accessibility early in the development process.
Develop a couple of pages in ToolBook and then use the Publish to Web option in the File menu. The
This process will convert your pages into Web pages, and you can test these Web pages in a browser
while running any kind of assistive technology that is available to you.

» Keep the following tips in mind to make your content accessible:
e add a brief description for each graphic you include

e use a text color that provides strong contrast with the background color

create a logical tab order on the page
e trigger an audio file with a Play Media Player button
e create a transcript or descriptive text for audio or video files

In ToolBook you can enter a short description for a graphic that will appear in pop-up window in a
browser. This text will allow people who cannot see the graphic or have graphics turned off to
understand what is displayed on the page. Enter your descriptive text in the tooltip text field on the
Behavior tab of the properties dialog box for a graphic, and this tooltip text will be exported in the Alt
tag in the HTML files that ToolBook generates (as long as you accept the default option labeled “Convert
tooltips to alternate text attributes” when you publish your book). You can enter tooltip text for any
graphic that is shown in the Web Graphic placeholder object, as well as any picture object, paint object,
draw object, or button that displays a graphic.

Using a text color that contrasts strongly with the background color (such as black text on a white
background) makes it easier for people with some types of vision impairments to read the text. Try to
avoid the use of colored text to convey a message by color alone, as people who are colorblind could
not understand this visual convention.

A logical tab order makes it easier to understand the content on a page when navigating by using the
keyboard, and allows people who use the Tab key to move the focus from object to object to access
your content.

You can set a meaningful left-to-right sequence for the tab order as well as a top-to-bottom tab
sequence in ToolBook. Initially the tab order follows the order in which objects are added to the page.
To set a logical tab order, select the objects on the page that you want to include in the tab order and
then open the Set Tab Order dialog box: From the Draw menu, point to Layer, and choose Set Tab Order.
The tab order will remain the same after you publish your book to the Web.

If you want to include an audio file, you can add a Play Media Player button from the Accessibility
Catalog to your page in addition to a media player. Adding this button allows a person to use the Tab
key to move the focus to the Play Media Player button and start the audio file. Using the Tab key to
access buttons is essential for people who are using screen reader software.

You can create a text transcript or descriptive narrative for an audio file or video file by adding a
scrolling text field to your page and entering the appropriate text. Another way to show a transcript is to
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use a button that displays a pop-up page when clicked. Assign a hyperlink to the button that causes the
pop-up page to appear, and set the Skip Navigation property for the page that pops up to True so that
this page will not be displayed when the user navigates through the course. A third option is to use the
Open Document button to display a text file that contains the transcript text. The Open Document
button is available in the Action Objects category of the Accessibility Catalog.

About the Accessibility Catalog

The Accessibility Catalog contains a selection of authoring objects that can display content in an
accessible format. All objects in the Accessibility Catalog are built to be delivered as Web pages that use
DHTML. For a description of any object in the Catalog, point to the object and a pop-up description will
display. Quick steps to using an object from the Accessibility Catalog are available when you drag an
object from the Catalog to a page and display the ToolBook Coach. Open the Coach by clicking the Help
menu and choosing Coach.

In order to make your content available to people using assistive technologies, some of the objects in
the Accessibility Catalog may need to be used in conjunction with other objects. Accessibility
considerations for specific categories of objects are discussed below.

Action Objects

The buttons in the Action Objects category are able to hide and show objects and create dynamic
effects. You can use these buttons in ways that can be interpreted by assistive technologies such as
screen readers. For example, you could use an Action Trigger button to display a hidden text field that
provides additional information. A screen reader will be able to vocalize the text in the hidden text field
after the text field is displayed. If you choose to display visual effects that people with visual
impairments will not be able to see, you can add a text description that explains what is happening on
the screen.

Text fields

Text is usually easy to access. If you plan to include a text field which allows the user to enter text at
Reader level, you should include the text field in the tab order.

Media players

To allow a person to use the keyboard to navigate to a button that will start an audio or video file, add a
Play Media Player button to your page. A Play Media Player button works in conjunction with a media
player from the Media Players category, providing an alternate way to trigger the media. Individual
buttons are also available to stop and pause the media file. Using the keyboard for navigation is
necessary for some types of assistive technologies.

Since people with vision impairments can’t see video and animation files, you can add a text description
or transcript to convey the content of any media files that you include.
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Opening the Accessibility Catalog

ToolBook will display the Accessibility Catalog in a book when you open it. To change the current catalog
shown in ToolBook, click the Object menu, choose Properties for Book, and then click the General tab in
the Properties for Book dialog box. Enter the name and location of the .ini file that defines the
Accessibility Catalog (by default, for ToolBook this is c:\Program Files\ToolBook\ToolBook
11.5\Accessibility Catalog\catalog.ini).

About the accessibility options in DHTML content

After you create a course or content in ToolBook, you prepare the pages for delivery by using the
Publish to Web option in the File menu.

Within you will find accessibility options. Enabling these options will allow ToolBook to Publish files that
will be accessible to the widest audience possible.

The option labeled “Convert tooltips to alternate text attributes” allows the text that you enter in the
tooltip field of a properties dialog box for a graphic to be exported in a format that can be interpreted
and vocalized by screen reader software.



