Getting Started with ToolBook 11.5
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>CHAPTER</th>
<th>PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>INTRODUCTION</td>
<td>4</td>
</tr>
<tr>
<td>About this book</td>
<td>5</td>
</tr>
<tr>
<td>System requirements</td>
<td>5</td>
</tr>
<tr>
<td>Installing ToolBook</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>CREATING A NEW COURSE</td>
<td>6</td>
</tr>
<tr>
<td>Starting ToolBook</td>
<td>7</td>
</tr>
<tr>
<td>Beginning a new book</td>
<td>7</td>
</tr>
<tr>
<td>Changing the text in the title bar</td>
<td>8</td>
</tr>
<tr>
<td>3</td>
<td>9</td>
</tr>
<tr>
<td>WORKING WITH PAGES</td>
<td>9</td>
</tr>
<tr>
<td>Switching views</td>
<td>10</td>
</tr>
<tr>
<td>Navigating between pages</td>
<td>10</td>
</tr>
<tr>
<td>Adding new pages</td>
<td>10</td>
</tr>
<tr>
<td>Adding a Certificate page</td>
<td>11</td>
</tr>
<tr>
<td>Deleting pages</td>
<td>11</td>
</tr>
<tr>
<td>Viewing the background</td>
<td>11</td>
</tr>
<tr>
<td>Changing the page size</td>
<td>12</td>
</tr>
<tr>
<td>4</td>
<td>13</td>
</tr>
<tr>
<td>USING THE CATALOG</td>
<td>13</td>
</tr>
<tr>
<td>Adding objects from the catalog</td>
<td>14</td>
</tr>
<tr>
<td>Searching for objects</td>
<td>15</td>
</tr>
<tr>
<td>Hiding categories</td>
<td>15</td>
</tr>
<tr>
<td>Positioning the catalog window</td>
<td>15</td>
</tr>
</tbody>
</table>
CHAPTER 5........................................................................................................................................... 16

ADDING TEXT AND GRAPHICS ............................................................................................................. 16
Entering text ........................................................................................................................................ 17
Formatting text .................................................................................................................................. 18
Turning text into a link ......................................................................................................................... 18
Adding graphics and photos ............................................................................................................... 19
Playing video, audio, and Flash files .................................................................................................. 19

CHAPTER 6........................................................................................................................................... 20

WORKING WITH OBJECTS AND PROPERTIES .................................................................................. 20
Using the Book Explorer ..................................................................................................................... 21
Setting properties ............................................................................................................................... 22
Understanding extended properties .................................................................................................. 22
Selecting objects ................................................................................................................................. 23
Changing the size and shape of objects .............................................................................................. 23
Moving objects between layers ........................................................................................................... 23

CHAPTER 7........................................................................................................................................... 25

PREPARING A BOOK FOR WEB DELIVERY ...................................................................................... 25
Delivering web pages .......................................................................................................................... 26
Publishing to Web ............................................................................................................................... 26

CHAPTER 8........................................................................................................................................... 28

SCORING TESTS AND TRACKING WITH AN LMS .......................................................................... 28
Building an assessment ....................................................................................................................... 29
Creating a quiz summary ..................................................................................................................... 29
Preparing content for an LMS ............................................................................................................ 30
Further information ............................................................................................................................. 30
INTRODUCTION

This chapter describes what you will find in this book. System requirements and installation instructions for ToolBook are included.
About this book

This book covers the basic aspects of creating online content with ToolBook: start with a template, add your text and graphics, and then use the Publish to Web menu command to automatically build web pages.

For more detailed information about the features in ToolBook™ consult the User Guide that ships with ToolBook; this PDF file is available from the Help menu after you start ToolBook.

System requirements

Your computer must meet the minimum requirements described below to run the ToolBook authoring software.

Operating systems

- Windows XP Professional SP2 (or later), Windows Vista or Windows 7

Hardware Minimum Requirements

- Intel Pentium® processor (or compatible) processor 1 GHz
- 1 gigabyte (GB) of Random Access Memory (RAM)
- 600 MB of free hard disk space
- Graphics card capable of 800 x 600 pixel display with 24-bit color (higher recommended)

Installing ToolBook

To install ToolBook using the setup program provided to you, double-click on the file and follow the prompts shown on the screen.
CHAPTER 2

CREATING A NEW COURSE

Courses you create in ToolBook are stored in files having the extension .tbk, and are referred to as "books." A book contains pages on which content is placed by the author.

You can create a new book using a wizard that gathers input from you and prepares pages with a consistent theme and layout.
Starting ToolBook

- To start ToolBook:
  - Click the Start button on the taskbar. Point to Programs, ToolBook 11.5, and click ToolBook 11.5.

Beginning a new book

A book is a collection of pages stored as a single ToolBook file. You can start a new book using the Blank, From a Template or Use a Book Wizard options on the Startup screen that displays as soon as you open ToolBook.

![ToolBook 11.5 Startup](image)

*Figure 1 The Startup dialog box*

- To create a new book using the Book Wizard:
  1. Open ToolBook from the Start button on the Windows taskbar.
  2. Click the Use a Book Wizard option.
  3. Select the Book Wizard option.
4. Click **Start Wizard**.

5. Follow the instructions on the screen.

**Changing the text in the title bar**

Every book has a title that displays in the title bar. You can edit the default title assigned to a book.

*Figure 2* Title of a book displays at the top of the window

❖ **To change the title of a book:**

1. From the **Object** menu choose **Properties for Book**.

2. Click the **Summary** tab.

3. Enter text in the **Book title** field.

4. Close the dialog box to save your title.
WORKING WITH PAGES

You will find out how to move between the authoring workspace and the view of content that learners see, called Reader level, in this chapter. Important authoring tasks such as adding new pages, navigating between pages, and switching to the background of a page are described.
Switching views

When you first open ToolBook, you see the Author level workspace. Author level is where you build content by entering text, adding graphics, and more. The catalog is available at Author level along with other development tools such as the shortcut menus, toolbar, Book Explorer, and ToolBook Coach.

You can switch to Reader level to see how pages will look to the end users.

❖ To switch from Author level to Reader level:

1. From the View menu select Reader.
2. Press F3 to return to Author level, or click the View menu and select Author.

You can test links and other functionality at Reader level.

Several changes take place when you switch from Author level to Reader level. At Reader level:

- Menus do not contain the development-related commands, and shortcut menus are disabled.
- The authoring tools are not available, such as the toolbar and catalog.

Navigating between pages

You can move from one page to another in a book using the:

- Arrow keys on the keyboard: press while the ALT key is held down.
- Previous Page or Next Page buttons on the status bar.
- Book Explorer.
- Go menu.

The Book Explorer provides a visual way to locate and navigate to pages.

You can also navigate by entering a page name, number, or id number in the Go To dialog box, available from the Edit menu.

Adding new pages

If you have started a book using a template or a Book Wizard, the fastest way to add new pages is to select one from the catalog. A new page from the catalog will match the style of your book.

❖ To add a new page in a matching style:

1. If the catalog is not open, from the View menu choose Catalog.
2. Click the Pages category.
3. Point to any small page image to view a description of the page.
4. Drag a page from the catalog to your book. The new page will match the existing look of your book.

If you want a page that has nothing on it, you can add a blank page by opening the Insert menu and choosing New Page.

**Adding a Certificate page**

A Certificate page is available in the Certificates category of the catalog. For details on using the Certificate page, refer to the Online Help.

**Deleting pages**

Once a page is deleted, it cannot be recovered.

- **To delete a page:**
  1. From the *Edit* menu choose *Select Page*.
  2. Press the *Delete* key.

**Viewing the background**

A button or any other object placed on the background will display on all pages that share the same background.

- **To move to the background of a page:**
  1. From the *View* menu, select *Background*.

The background pictured below contains a graphical look and navigation buttons, which display on all pages that use the background.

![Page View and Background View](image)

*Figure 1 Page View and Background View*

A background is the foundation for a page. Many pages can share a single background.
Changing the page size

A page has the same size as its background.

❖ To change the page size:

1. From the Object menu select Properties for Background.
2. Click the Page tab.
3. Remove the check from the box labeled "Use the book default page size".
4. Select a page size.

If you have multiple backgrounds in a book, keep in mind that a web browser has a set window size that will not resize to fit different page sizes. When ToolBook prepares web pages from a book, the browser window will be set to the size of the largest background in a book.
CHAPTER 4

USING THE CATALOG

The catalog contains a variety of objects such as questions and text fields. You can browse through the catalog to find objects that you can use. This chapter explains how to add catalog objects to your content. Also, you'll find out how to hide or show categories in the catalog and position the catalog window.
Adding objects from the catalog

The catalog contains a collection of objects that you can add to pages. Text fields, buttons, and interactive questions are some of the objects you will find in the catalog.

![Catalog](image)

**Figure 1  The Catalog**

When you click a category button in the catalog, small thumbnail images of objects appear below the category button. You can drag one of these thumbnails to a page to add the object to your book.

- **To display the catalog:**
  - From the View menu select Catalog.

For a description of a catalog object, point to the thumbnail image in the catalog and pop-up text will display.

- **To add a catalog object to a page:**
  - Choose an object in the catalog and drag it from the catalog to the page.

As soon as you add a catalog object to a page, the properties dialog box for that object will open to allow you to set options.
For information about setting up a catalog object, read the steps shown in the ToolBook Coach. Open the Coach from the Help menu. Select an object on the page and the Coach displays steps to use it.

**Searching for objects**

You can enter search words to find any catalog objects with a description or name that matches your entry.

- **To search for an object in the catalog:**
  1. Open the catalog if it is not currently open.
  2. Point at one of the category captions within the Catalog window and right-click.
  3. From the right-click menu, choose Find Object.
  4. Enter a keyword in the Find Object dialog box.
  5. Click the Find button.

**Hiding categories**

All of the categories available in the catalog may or may not be visible, depending on your preference. You can display categories that are not shown by default by selecting the categories you want to view.

- **To change the display of categories in the catalog:**
  1. Open the catalog if it is not currently open.
  2. From the View menu choose Customize Catalog.
  3. Select one or more categories that you want to display and then click OK.

**Positioning the catalog window**

You can choose the location for the catalog. It can be attached to the left or right side of the ToolBook window, or shown as a floating window.

- **To change the location of the catalog window:**
  1. Open the catalog if it is not currently open.
  2. Position the catalog to the left or right docked position, or an undocked position by dragging the caption bar of the Catalog window to the required location.
CHAPTER 5

ADDING TEXT AND GRAPHICS

You add text to a book by placing text in text fields. This chapter describes how to enter and format text, and how to incorporate graphics and media files in a book.
**Entering text**

You add text to a page by placing text in a text field. ToolBook provides a wide variety of text fields in the catalog. Some examples of text fields are shown below.

![Text can be shown in a field without a border](image)

**Figure 1 Examples of text fields**

You can drag any text field you want from the catalog to a page.

- **To type text in a field:**
  - Double-click a text field and enter text.

When the insertion point displays in a text field to allow you to enter text, you can move the insertion point to a different text field by clicking only once.

- **To paste text into a field:**
  1. Open the file that contains the text you want and copy the text.
  2. In ToolBook, double-click the text field where you will paste the text. This will result in a blinking I-Beam blinking in the field.
  3. From the **Edit** menu choose **Paste**.

You can also use the standard Windows shortcut keys for copy and paste: CTRL+C and CTRL+V.

If you copy text from Microsoft Word and paste it into ToolBook, some kinds of formatting may not display as expected. To remove formatting from a selection (such as that from a web page or a Microsoft Word document), use the **Paste Unformatted Text** option in the **Edit** menu, or CTRL+SHIFT+V.

- **To import text:**
  1. Double-click the field that will hold the text you import. This will result in a blinking I-Beam blinking in the field.
  2. From the **Insert** menu choose **Text**.
  3. In the Import Text dialog box, choose an RTF file or a TXT file and click **Open**.
Formatting text

Every text field has default text properties such as font color and font size. You can format text by applying a format to selected characters or change the paragraph formatting for an entire text field.

❖ To change the formatting for all text in a field:

1. Select a field by clicking it once.
2. From the Object menu choose Properties for Text Field.
3. Click the Paragraph tab to change the alignment, spacing, or indents of the text.
4. Click the Font tab to change the font type, style, or size.
5. Close the Properties dialog box.

❖ To format selected characters:

1. Select the words you want to format.
2. From the Object menu choose Properties for Text Field.
3. On the Font tab, choose the font style, text color, size, or effects you want.
4. Close the Properties dialog box.

Turning text into a link

A link allows the user to jump from one page to another. The page which opens may be a different page in a book or a web page on the Internet.

One option is to set up a link that navigates to another page. Another option is to create a link that opens a pop-up window to show a different page.

❖ To create a link to another page:

1. Select the word or characters that will become the link.
2. From the Object menu choose Hyperlink.
3. In the Type of link list, select the kind of link you want to use.
4. Under Link to, select the type of link you want, and click OK.

If you want to change the color or appearance of a link, select it, open the Object menu, and choose Properties for Hotword.
**Adding graphics and photos**

When you paste a graphic on a page or import an image, ToolBook adds the graphic file to the book's resource system and displays it on the page, within an Image object. You can add a border by selecting the Image object, opening the Properties dialog box, and choosing a border line style setting.

During the publish to web process, ToolBook exports all graphics to the Internet compatible file formats of JPEG, GIF, or PNG.

- **To import a graphic:**
  1. From the **Insert** menu choose **Graphic**.
  2. Select the source file in the Import Graphic dialog box.

ToolBook imports the graphic and displays it on the page or background within an Image object. Pasting a graphic in ToolBook will also result in the image being shown within an Image object.

- **To display a graphic using an Image object placeholder:**
  1. Open the catalog.
  2. Choose the **Commonly Used Objects** category.
  3. Locate the **Image** object and drag it to a page.
  4. In the Choose resource for Image object dialog, choose the image you want displayed or click **Cancel** if you want to set this up later.

**Playing video, audio, and Flash files**

The Universal Media Player is the easiest to use and most versatile of all the media player objects available in ToolBook. You simply choose the file to display, and ToolBook automatically presents the appropriate player at Reader level. A wide variety of file formats are supported.

- **To add a Universal Media Player:**
  1. If the catalog is not currently open, from the **View** menu choose **Catalog**.
  2. Open the **Media Players** category, select the **Universal Media Player**, and drag it to your page.
  3. When the Properties dialog box opens, select the file to play.

The Universal Audio Player is also available if your media is an audio file.
CHAPTER 6

WORKING WITH OBJECTS AND PROPERTIES

Properties for an object include the color, size, and location of an object on a page. You can modify the default property settings to change the appearance and sometimes the behavior of an object.

All of the objects on each page are shown in an outline view in the Book Explorer. This interactive object browser allows you to rearrange and edit pages, view miniature page images, access properties, and more.
Using the Book Explorer

All of the objects on each page of a book are listed in an outline view in the Book Explorer. In this interactive browser, you can move objects, view page thumbnail images, and navigate to any page you select.

![Book Explorer](image)

**Figure 1** The Book Explorer

Selecting an object in the Book Explorer causes it to be selected in the main window as well. When you select a page name, the page displays in the main window.

A small preview image of a page appears next to the Book Explorer if you point to a page name with the mouse.

You can reorder pages in the Book Explorer to arrange the sequence of pages by using drag and drop. Move an object to another page or a different layer on a page by dragging the object to a new location in the Book Explorer.

❖ To open the Book Explorer:

- From the View menu select Book Explorer.

<table>
<thead>
<tr>
<th>In the Book Explorer, to...</th>
<th>Do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview a page</td>
<td>Point to a page name using the mouse.</td>
</tr>
<tr>
<td>Select an object</td>
<td>Click it once, and ToolBook will select the object in the main window also.</td>
</tr>
<tr>
<td>Navigate to a page</td>
<td>Click the name of a page.</td>
</tr>
<tr>
<td>Move a page</td>
<td>Drag it up or down in the list of pages.</td>
</tr>
<tr>
<td>Move an object to a different layer or page</td>
<td>Select an object, drag it up or down the list, and drop it where you want it.</td>
</tr>
<tr>
<td>Open the shortcut menu for an object</td>
<td>Right-click an object in the Book Explorer.</td>
</tr>
</tbody>
</table>
Setting properties

All objects in ToolBook (such as buttons) have properties that define their look and behavior. The properties you can set for a button, for example, include the color, caption, size, location, and so on.

You can set properties by selecting an object and opening the Properties dialog box. Changes that you make in the Properties dialog box take place immediately.

❖ To display the Properties dialog box:

• Click the Properties button on the toolbar.

The settings in the Properties dialog box apply to the currently selected object. Options and tabs available in the Properties dialog box change according to the currently selected object.

![Properties for Button](image)

Figure 2 The Properties dialog box

Understanding extended properties

Catalog objects often have properties that set sophisticated capabilities in addition to the standard properties for an object. These properties are called extended properties. A multiple choice question object, for example, has extended properties that define the correct answers, incorrect answers, and the score for the question.

You can set extended properties for catalog objects in the Extended Properties dialog box. To see whether an object has extended properties, select the object and look at the Extended Properties button on the toolbar. This button is available only when you select an object with extended properties.

❖ To set extended properties for an object:

1. Select the object.

2. Click the Extended Properties button on the toolbar.

3. Specify the options you want in the dialog box and click OK.
Many of the objects in the catalog are actually a group of individual objects. If you double-click an individual object inside a group, you can access the standard properties for the selected object.

**Selecting objects**

When you select an object, ToolBook displays small *handles* around the object.

![Handles](image)

*Figure 3  Selection handles*

You can select single or multiple objects. If you select multiple objects, your next mouse action or command affects all of the selected objects. For example, if you selected two objects, you could cut or copy them as if you had selected a single object.

<table>
<thead>
<tr>
<th>To select...</th>
<th>Do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>A single object</td>
<td>Click the object.</td>
</tr>
<tr>
<td>Multiple objects</td>
<td>SHIFT+Click each object.</td>
</tr>
<tr>
<td>All objects on the page</td>
<td>From the Edit menu choose Select All.</td>
</tr>
</tbody>
</table>

**Changing the size and shape of objects**

You can change the size and shape of any object by dragging a sizing handle.

- **To change the size of an object:**
  1. Select the object you want to resize.
  2. Drag a handle until the object is the size you want.

  *If you want to resize an object proportionally, press CTRL as you drag a corner handle.*

**Moving objects between layers**

When you add a button or another object to a page, ToolBook adds a layer to the front of the current page and then places the button on that layer. When objects overlap, the objects on higher layers appear to be placed on top of objects on lower layers.

- **To move an object to a higher or lower layer:**
  1. If the Book Explorer is not open, from the View menu choose Book Explorer.
2. Select the object you want to move in the Book Explorer window.

3. Drag the selected object up the list or down the list and drop it where you want it to be. ToolBook assigns new layer numbers to all of the objects affected by the change.
CHAPTER 7

PREPARING A BOOK FOR WEB DELIVERY

ToolBook provides a wizard that takes you through the process of preparing a book for use on the Internet. After you respond to the prompts shown in the wizard, ToolBook builds the web pages for you.
Delivering web pages

ToolBook can Publish your book as a series of web pages that incorporate DHTML automatically. Dynamic HTML, or DHTML, extends HTML by adding the ability to create interactive features such as buttons that respond to a click, scrolling text, animations and more. In ToolBook, the preprogrammed objects in the catalog have these features built in.

ToolBook builds web pages from your book when you choose Publish to Web from the File menu.

Publishing to Web

You start this process of creating web pages by choosing Publish to Web from the File menu.

Figure 1  Publish to Web

❖ To prepare web pages:

1. Open the book you want to Publish.

2. From the File menu, select Publish to Web (DHTML).

3. Adjust the Publishing settings as needed.

4. Click the Publish button to start the process.

As soon as the Publishing process is finished, you can view the web pages in a web browser. The file named INDEX.HTML opens the first page in the series of Published web pages.

You can access the folder containing the index.html from a link displayed after publishing, as shown below.
Figure 2  Link to the WebExport folder
CHAPTER 8

SCORING TESTS AND TRACKING WITH AN LMS

You may include questions as part of a quiz or assessment you create in ToolBook. The catalog has question objects that determine what responses individual users make. ToolBook calculates the score for answers.

Assessment results can be stored by a learning management system (LMS). An LMS that conforms to the SCORM or AICC standards can track the scores that learners earn when taking ToolBook courses.
Building an assessment

An assessment is a test or quiz with questions to be answered by each person who takes the course. You can create an assessment in ToolBook in either of these ways:

- Add a question object from the catalog to a page. **Question Objects** are available in the Questions category of the catalog.
- Start a book from a quiz Template.
- Start a new book with the **Book Wizard** and choose the **Quiz Book** option.

The score and answer options for a question are available by opening the extended properties for the question as described below.

 ❖ **To set the correct answer for a question:**

1. Select a question object on a page.
2. Click the **Extended Properties** button on the toolbar.
3. Click the **Answers** tab in the Properties for Question dialog box.
4. Each answer choice displays a checked graphic or incorrect graphic to the left; click this graphic to change the setting.

If you want to display a student’s score, use the Show Score or Score this Quiz buttons available from the catalog in the Scoring and Tracking category. These buttons calculate the score and display the results in a Score Field object, which is also available from the catalog.

With most types of question objects you can assign a weight to every answer. You can modify the default weights in the Properties for Question dialog box.

Feedback is the way a question object responds when a learner enters an answer. For example, a question object can display the word "Correct" in a pop-up box after a learner chooses the right answer. Descriptions of the different types of feedback are provided in Online Help.

Creating a quiz summary

ToolBook has a Quiz Summary feature that is used to display the results of a quiz to the learner. In Author mode, the quiz summary displays generic text for various question properties such as the question name, question text, and the student answer. While taking the course, the learner will see this generic text replaced with the actual values from each question. As a course author, you can add, remove, and rearrange these text fields as required.

To use the quiz summary feature, add a quiz summary object to a page by dragging it out of the "Quiz Summary" category of the catalog, and dropping it onto the page. A Properties dialog will appear, allowing you to customize many options and properties of the quiz summary.
Preparing content for an LMS

If you plan to publish pages created in ToolBook through a learning management system:

- Include an Exit button on one or more of the pages to allow the score and completion information to be sent to the LMS. Exit buttons are located in the catalog in the Scoring and Tracking category.

- Prepare the ToolBook course for delivery. From the File menu, choose Publish to Web (DHTML). ToolBook creates a single package file that you can publish through an LMS.

When you prepare your book for delivery using the Publish to Web feature, add SCORM or AICC support by selecting the appropriate option. This allows quiz and assessment results to be tracked and stored in an LMS database. ToolBook sends a learner's score to the LMS when the learner clicks the Exit button prepared for this purpose.

You may use more than one type of Exit button. For instance, you might use an Exit (Suspend Lesson) button on most pages to allow the learner to stop after finishing part of the course and resume it at a later time. On the final page, you could replace the button with the Exit (Mark as Complete) button, to record the final score and mark the course as complete in the LMS.

While you are creating content in ToolBook, you can test it by using the Publish to Web command from the File menu. View the Published pages in a web browser to make sure they meet expectations. If your LMS provides a testing environment, it's best to launch the content through the LMS and go through each page before releasing the content to the intended audience. Verify that the score displays appropriately and graphics appear as you intended. Check to see if each link opens the correct page. Test the content in all browsers that your audience may use.

Further information

An online User Guide is available from the Help menu in ToolBook. This book explains the interface, tools, menus, and many features of ToolBook. Detailed information is also available from online Help.

For access to tutorials and other resources, visit the following link: http://www.toolbook.com/faq